Help Center

What version of android or iPhone is compatible to the Road-Eyes App?

Kate -

The compatible version for the app is the iOS 8 minimum (iPhone 4s and newer) and Android version 4.0 minimum (and newer).

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk